Skip to main content

Known exploited vulnerability · CISA KEV

CVE-2023-32315: Ignite Realtime Openfire Path Traversal Vulnerability

Ignite Realtime Openfire contains a path traversal vulnerability that allows an unauthenticated attacker to access restricted pages in the Openfire Admin Console reserved for administrative users.

CVE-2023-32315

Exploited in the wild. Fix this first.

CISA added it to the Known Exploited Vulnerabilities catalog on 2023-08-24: attackers are using it right now.

CISA KEV
Listed
Added 2023-08-24 · federal fix-by 2023-09-14
EPSS (30 days)
over 99.9%
Higher than 99.9% of CVEs · 2026-11-01
CVSS v3.1
7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

What CISA says

Ignite Realtime Openfire Path Traversal Vulnerability

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

NVD description · published 2023-05-26

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Full record on NVD

Got a whole scan? Scan Hub runs this check on every finding in your Nessus, Qualys, Rapid7 or OpenVAS export and ranks the report by it.

Try it free

How to check if you are exposed to CVE-2023-32315

  1. Find every Ignite Realtime Openfire system you or your clients run, including ones exposed to the internet. Those come first: CISA only lists flaws attackers are already using.
  2. Compare each version with the fixed versions in the vendor advisory below. Where no fix exists yet, apply the vendor’s mitigation or take the system off the internet.
  3. Run a credentialed vulnerability scan to catch the systems you missed, then check that the next scan no longer reports CVE-2023-32315.

US federal agencies had to fix this by 2023-09-14. Everyone else should treat that deadline as a guide: if it has passed, this is overdue.

Affected versions

Versions the National Vulnerability Database lists as vulnerable to CVE-2023-32315. Check the vendor advisory for the exact fixed builds before you sign anything off.

ProductVulnerable versions
Ignite Realtime Openfirefrom 3.10.0 before 4.6.8; from 4.7.0 before 4.7.5

Timeline

  1. · Published in the National Vulnerability Database
  2. · Added to CISA's Known Exploited Vulnerabilities catalog, 90 days after it was published
  3. · Fix-by date for US federal agencies, passed 1,144 days ago

Vendor advisories and fixes

Weakness type

Keep going

Sources: CISA Known Exploited Vulnerabilities catalog (version 2026.10.30); EPSS data from FIRST.org; CVSS and descriptions from the NIST National Vulnerability Database. Checked 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

Cookie preferences

Essential site functions remain available whichever option you choose. Your advertising choice is saved on this site. The Scan Hub has a separate choice.

Google and Reddit may receive cookies, identifiers, browser and device information, and your network/IP information. Reject or withdraw at any time. Read the Privacy Policy.