Skip to main content

Known exploited vulnerability · CISA KEV

CVE-2024-51567: CyberPanel Incorrect Default Permissions Vulnerability

CyberPanel contains an incorrect default permissions vulnerability that allows a remote, unauthenticated attacker to execute commands as root.

CVE-2024-51567

Exploited in the wild. Fix this first.

CISA added it to the Known Exploited Vulnerabilities catalog on 2024-11-07: attackers are using it right now. It is known to be used in ransomware campaigns.

CISA KEV
Listed
Added 2024-11-07 · federal fix-by 2024-11-28
EPSS (30 days)
84%
Higher than 99.7% of CVEs · 2026-11-01
CVSS v3.1
9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What CISA says

CyberPanel Incorrect Default Permissions Vulnerability

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

NVD description · published 2024-10-29

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

Full record on NVD

Got a whole scan? Scan Hub runs this check on every finding in your Nessus, Qualys, Rapid7 or OpenVAS export and ranks the report by it.

Try it free

How to check if you are exposed to CVE-2024-51567

  1. Find every CyberPersons CyberPanel system you or your clients run, including ones exposed to the internet. Those come first: CISA only lists flaws attackers are already using.
  2. Compare each version with the fixed versions in the vendor advisory below. Where no fix exists yet, apply the vendor’s mitigation or take the system off the internet.
  3. Run a credentialed vulnerability scan to catch the systems you missed, then check that the next scan no longer reports CVE-2024-51567.

US federal agencies had to fix this by 2024-11-28. Everyone else should treat that deadline as a guide: if it has passed, this is overdue.

Affected versions

Versions the National Vulnerability Database lists as vulnerable to CVE-2024-51567. Check the vendor advisory for the exact fixed builds before you sign anything off.

ProductVulnerable versions
Cyberpanelbefore 2.3.8

Timeline

  1. · Published in the National Vulnerability Database
  2. · Added to CISA's Known Exploited Vulnerabilities catalog, 9 days after it was published
  3. · Fix-by date for US federal agencies, passed 703 days ago

Vendor advisories and fixes

Weakness type

More exploited CyberPersons vulnerabilities

CISA lists 2 exploited CyberPersons vulnerabilities. The closest matches:

Keep going

Sources: CISA Known Exploited Vulnerabilities catalog (version 2026.10.30); EPSS data from FIRST.org; CVSS and descriptions from the NIST National Vulnerability Database. Checked 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

Cookie preferences

Essential site functions remain available whichever option you choose. Your advertising choice is saved on this site. The Scan Hub has a separate choice.

Google and Reddit may receive cookies, identifiers, browser and device information, and your network/IP information. Reject or withdraw at any time. Read the Privacy Policy.