Skip to main content

Known exploited vulnerability · CISA KEV

CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability

BerriAI LiteLLM contains a SQL injection vulnerability that allows an attacker to read data from the proxy's database and potentially modify it, leading to unauthorized access to the proxy and the credentials it manages.

CVE-2026-42208

Exploited in the wild. Fix this first.

CISA added it to the Known Exploited Vulnerabilities catalog on 2026-05-08: attackers are using it right now.

CISA KEV
Listed
Added 2026-05-08 · federal fix-by 2026-05-11
EPSS (30 days)
89%
Higher than 99.8% of CVEs · 2026-11-01
CVSS v4.0
9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

What CISA says

BerriAI LiteLLM SQL Injection Vulnerability

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

NVD description · published 2026-05-08

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

Full record on NVD

Got a whole scan? Scan Hub runs this check on every finding in your Nessus, Qualys, Rapid7 or OpenVAS export and ranks the report by it.

Try it free

How to check if you are exposed to CVE-2026-42208

  1. Find every BerriAI LiteLLM system you or your clients run, including ones exposed to the internet. Those come first: CISA only lists flaws attackers are already using.
  2. Compare each version with the fixed versions in the vendor advisory below. Where no fix exists yet, apply the vendor’s mitigation or take the system off the internet.
  3. Run a credentialed vulnerability scan to catch the systems you missed, then check that the next scan no longer reports CVE-2026-42208.

US federal agencies had to fix this by 2026-05-11. Everyone else should treat that deadline as a guide: if it has passed, this is overdue.

Affected versions

Versions the National Vulnerability Database lists as vulnerable to CVE-2026-42208. Check the vendor advisory for the exact fixed builds before you sign anything off.

ProductVulnerable versions
Litellmfrom 1.81.16 before 1.83.7

Timeline

  1. · Published in the National Vulnerability Database
  2. · Added to CISA's Known Exploited Vulnerabilities catalog, the same day it was published
  3. · Fix-by date for US federal agencies, passed 174 days ago

Vendor advisories and fixes

Weakness type

More exploited BerriAI vulnerabilities

CISA lists 3 exploited BerriAI vulnerabilities. The closest matches:

Keep going

Sources: CISA Known Exploited Vulnerabilities catalog (version 2026.10.30); EPSS data from FIRST.org; CVSS and descriptions from the NIST National Vulnerability Database. Checked 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

Cookie preferences

Essential site functions remain available whichever option you choose. Your advertising choice is saved on this site. The Scan Hub has a separate choice.

Google and Reddit may receive cookies, identifiers, browser and device information, and your network/IP information. Reject or withdraw at any time. Read the Privacy Policy.