Skip to main content

Known exploited vulnerability · CISA KEV

CVE-2026-42271: BerriAI LiteLLM Command Injection Vulnerability

BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.

CVE-2026-42271

Exploited in the wild. Fix this first.

CISA added it to the Known Exploited Vulnerabilities catalog on 2026-06-08: attackers are using it right now.

CISA KEV
Listed
Added 2026-06-08 · federal fix-by 2026-06-22
EPSS (30 days)
91%
Higher than 99.8% of CVEs · 2026-11-01
CVSS v4.0
8.7 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

What CISA says

BerriAI LiteLLM Command Injection Vulnerability

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

NVD description · published 2026-05-08

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Full record on NVD

Got a whole scan? Scan Hub runs this check on every finding in your Nessus, Qualys, Rapid7 or OpenVAS export and ranks the report by it.

Try it free

How to check if you are exposed to CVE-2026-42271

  1. Find every BerriAI LiteLLM system you or your clients run, including ones exposed to the internet. Those come first: CISA only lists flaws attackers are already using.
  2. Compare each version with the fixed versions in the vendor advisory below. Where no fix exists yet, apply the vendor’s mitigation or take the system off the internet.
  3. Run a credentialed vulnerability scan to catch the systems you missed, then check that the next scan no longer reports CVE-2026-42271.

US federal agencies had to fix this by 2026-06-22. Everyone else should treat that deadline as a guide: if it has passed, this is overdue.

Affected versions

Versions the National Vulnerability Database lists as vulnerable to CVE-2026-42271. Check the vendor advisory for the exact fixed builds before you sign anything off.

ProductVulnerable versions
Litellmfrom 1.74.2 before 1.83.7
Redhat Openshift AIfrom 2.25 before 2.25.8; from 3.3 before 3.3.4; 3.4

Timeline

  1. · Published in the National Vulnerability Database
  2. · Added to CISA's Known Exploited Vulnerabilities catalog, 31 days after it was published
  3. · Fix-by date for US federal agencies, passed 132 days ago

Vendor advisories and fixes

Weakness type

More exploited BerriAI vulnerabilities

CISA lists 3 exploited BerriAI vulnerabilities. The closest matches:

Keep going

Sources: CISA Known Exploited Vulnerabilities catalog (version 2026.10.30); EPSS data from FIRST.org; CVSS and descriptions from the NIST National Vulnerability Database. Checked 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

Cookie preferences

Essential site functions remain available whichever option you choose. Your advertising choice is saved on this site. The Scan Hub has a separate choice.

Google and Reddit may receive cookies, identifiers, browser and device information, and your network/IP information. Reject or withdraw at any time. Read the Privacy Policy.